Home > Programming > WPF Error: No imaging component suitable to complete this operation was found

WPF Error: No imaging component suitable to complete this operation was found

If you get an error containing

No imaging component suitable to complete this operation was found.

System.NotSupportedException: No imaging component suitable to complete this operation was found. ---> System.Runtime.InteropServices.COMException (0x88982F50): Exception from HRESULT: 0x88982F50</blockquote>

Stack Trace

--- End of inner exception stack trace ---
at System.Windows.Media.Imaging.BitmapDecoder.SetupDecoderFromUriOrStream(Uri uri, Stream stream, BitmapCacheOption cacheOption, Guid& clsId, Boolean& isOriginalWritable, Stream& uriStream, UnmanagedMemoryStream& unmanagedMemoryStream, SafeFileHandle& safeFilehandle)
at System.Windows.Media.Imaging.BitmapDecoder.CreateFromUriOrStream(Uri baseUri, Uri uri, Stream stream, BitmapCreateOptions createOptions, BitmapCacheOption cacheOption, RequestCachePolicy uriCachePolicy, Boolean insertInDecoderCache)
at System.Windows.Media.Imaging.BitmapFrame.CreateFromUriOrStream(Uri baseUri, Uri uri, Stream stream, BitmapCreateOptions createOptions, BitmapCacheOption cacheOption, RequestCachePolicy uriCachePolicy)
at System.Windows.Media.ImageSourceConverter.ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, Object value)
at System.ComponentModel.TypeConverter.ConvertFromString(ITypeDescriptorContext context, CultureInfo culture, String text)
at System.Windows.Markup.XamlTypeMapper.ParseProperty(Object targetObject, Type propType, String propName, Object dpOrPiOrFi, ITypeDescriptorContext typeContext, ParserContext parserContext, String value, Int16 converterTypeId)
--- End of inner exception stack trace ---

This could happen if your registry is not so correct.Or if you installed multiple media codecs and uninstall and clean etc. may have cleared the settings from the registry,Some are needed by WPF (See Imaging Overview)

FIX:

Copy this into a txt file and rename txt file wic.reg and run


Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}]

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}\Instance]

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}\Instance\{381DDA3C-9CE9-4834-A23E-1F98F8FC52BE}]
"CLSID"="{381DDA3C-9CE9-4834-A23E-1F98F8FC52BE}"

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}\Instance\{389EA17B-5078-4CDE-B6EF-25C15175C751}]
"CLSID"="{389EA17B-5078-4CDE-B6EF-25C15175C751}"

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}\Instance\{6B462062-7CBF-400D-9FDB-813DD10F2778}]
"CLSID"="{6B462062-7CBF-400D-9FDB-813DD10F2778}"

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}\Instance\{9456A480-E88B-43EA-9E73-0B2D9B71B1CA}]
"CLSID"="{9456A480-E88B-43EA-9E73-0B2D9B71B1CA}"

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}\Instance\{A26CEC36-234C-4950-AE16-E34AACE71D0D}]
"CLSID"="{A26CEC36-234C-4950-AE16-E34AACE71D0D}"
"FriendlyName"="WMPhoto Decoder"

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}\Instance\{B54E85D9-FE23-499F-8B88-6ACEA713752B}]
"CLSID"="{B54E85D9-FE23-499F-8B88-6ACEA713752B}"

[HKEY_CLASSES_ROOT\CLSID\{7ED96837-96F0-4812-B211-F13C24117ED3}\Instance\{C61BFCDF-2E0F-4AAD-A8D7-E06BAFEBCDFE}]

"CLSID"="{C61BFCDF-2E0F-4AAD-A8D7-E06BAFEBCDFE}"
About these ads
Categories: Programming
  1. TheLostLeaf
    15/07/2011 at 10:59 PM

    Another possible resolution is:

    If your client is running Windows XP and you are using an Icon in your WPF window. The Icon that shows up in the windows title bar… Remove that Icon and any icons in your program windows and it may resolve the error.

    Spent hours on this one more than once, and it always had to do with an Icon in the window. Note: other images will work inside the program but not an .ico in the Window Title.

    • Anonymous
      03/11/2012 at 9:39 PM

      I have the same problem while starting Visual C#2010 Express, so I cant even launch the program

      I tried above registrz settings, but it did not help.

      istro2000

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: