Home > Android, Programming, Windows Mobile > Android is not backward compatible

Android is not backward compatible

Newer releases from Google do not have an upgrade path for older older phones running older versions of  Android , mainly because Google only has
a model phone nexus they work with and the other phone manufactures are supposed to provide an upgrade path.

How long will this delivery model continue ?

Basically older phones work and some phone don’t just go out and buy a new phone each year when the older one just works fine.

Phone manufacturers don’t usually expect Apple (which is doing it the correct way) don’t have any intention of supporting new version of Android on their older phones.

Security wise this is a major screw up for Android which cannot be termed as a platform with this factor.

Main reason being the lack of resources from Google and Phone Manufactures who make billion out of the Phone but do not care about security and keeping
the consumer safe. (Would you buy a unsafe car?

Advertisements
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: